Deleting events from event sources taking longer than expected
Incident Report for Pipedream
Resolved
This incident is now resolved.
Posted Sep 23, 2020 - 22:26 UTC
Identified
Deleting events tied to event sources is currently taking longer than expected. If you attempt to delete events from the UI / API, you may notice some latency (you may notice that event still appears in the UI after you submitted the deletion request). We're working through the backlog of deletion requests and will update this incident when this issue is resolved.
Posted Sep 23, 2020 - 22:20 UTC
This incident affected: Backend (Event Sources - HTTP (Alpha), Event Sources - Timer (Alpha)).