Clicking into any workflow yields 404 error

Incident Report for Pipedream

Resolved

This incident has been resolved.
Posted Aug 30, 2024 - 17:19 UTC

Identified

We've identified a bug that causes workflows to throw a 404 error. We're addressing and will update here when it's resolved.
Posted Aug 30, 2024 - 17:15 UTC
This incident affected: Frontend (https://pipedream.com).