Connect API Latency

Incident Report for Pipedream

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 19:40 UTC

Identified

We have identified a latency issue with one of our downstream partner providers. We are currently evaluating ways to mitigate the effect.
Posted Aug 21, 2025 - 18:53 UTC

Investigating

We are currently investigating this issue.
Posted Aug 21, 2025 - 17:23 UTC
This incident affected: Connect (Connect) and Public APIs (Connect API).