Issues with connected accounts
Incident Report for Pipedream
Postmortem

We had a temporary connection issue with OAuth connected accounts starting at 14:14 UTC. We apologize for any downtime this may have caused for your workflows involving OAuth connected accounts.

The good news is we were able to recover many of these connections automatically using the refresh token sequence on the connected authentication APIs.

What happened

We pushed a change that caused the token refresh process for a handful of OAuth accounts to fail for roughly 2 hours. Certain apps (such as Discord and Zoom) immediately revoke previously-issued refresh tokens when a new refresh token request is made.

Because we do not log these tokens outside of our encrypted database, the refresh tokens we stored became out of sync with those the third party app assigned, and the accounts were no longer able to connect to the target API.

The resolution

We were able to rollback the change, and then trigger the rotation of refresh tokens using the original configuration.

This replaced the dead access tokens with live refreshed ones, restoring access to workflows. Simultaneously the app’s OAuth sequence was restored, allowing new accounts to be connected.

Going forward

We are tightening our controls around App updates and adding additional peer review policies to prevent this mistake from happening again in the future.

We are also adding additional monitoring to connected account heartbeats to ensure anomalies are detected sooner and automatically.

We appreciate your patience with this issue.

If you have additional questions, please reach out to us at support@pipedream.com

Posted Jul 26, 2022 - 17:39 UTC

Resolved
This incident has been resolved and the vast majority of OAuth connected accounts have been reconnected. The only affected provisioned accounts are OAuth authentication driven. API key based accounts were not affected.

We're working to restore the last OAuth affected accounts by triggering another refresh token sequence. However, if you see your accounts disconnected under your dashboard's connected accounts - reconnect them by hovering over the account and clicking the "Reconnect" option.
Posted Jul 26, 2022 - 17:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 26, 2022 - 16:01 UTC
Investigating
We have received reports of connected accounts unable to authenticate
Posted Jul 26, 2022 - 15:46 UTC
This incident affected: Integrations (Twitter).