root cause identified, Short term Mitigation efforts have been successful. Long term Mitigation solution has been identified and will be implemented as soon as the fix has passed our QA processes.
Posted Nov 04, 2025 - 19:14 UTC
Monitoring
Things have stabilized and we're continuing to monitor
Posted Nov 04, 2025 - 16:30 UTC
Investigating
We are currently investigating this issue.
Posted Nov 04, 2025 - 15:53 UTC
This incident affected: Public APIs (REST API, Connect API).