Some Connect Webhooks Experiencing Delays with Execution

Incident Report for Pipedream

Resolved

We are no longer seeing issues with Connect Webhooks. Triggers are executing normally once again.
Posted Jun 03, 2025 - 19:32 UTC

Monitoring

Connect Webhooks have now resumed their normal execution.
Posted Jun 03, 2025 - 17:51 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 03, 2025 - 17:49 UTC

Investigating

We are currently investigating this issue.
Posted Jun 03, 2025 - 16:24 UTC