Front End Instability

Incident Report for Pipedream

Resolved

Our front end services experienced unusual request patterns which led to degraded performance. We have updated our systems to address the issue and performance has returned to normal levels.
Posted Nov 20, 2025 - 02:17 UTC

Update

We are investigating instability with the Front End
Posted Nov 19, 2025 - 13:45 UTC

Investigating

We are currently investigating this issue.
Posted Nov 19, 2025 - 13:15 UTC
This incident affected: Frontend (Pipedream).