The platform has recovered from a previous outage. We will continue to monitor.

Incident Report for Pipedream

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 01:26 UTC

Monitoring

Event queues have caught up. We are continuing to monitor the platform.
Posted Oct 20, 2025 - 21:51 UTC

Update

Some services are starting to come back online, some of the queued events are being processed.
Posted Oct 20, 2025 - 20:05 UTC

Update

Multiple services are experiencing a service disruption as a result of a downstream provider (AWS). We are closely monitoring the status.
Posted Oct 20, 2025 - 16:24 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 16:15 UTC

Update

Multiple services are experiencing a service disruption as a result of a downstream provider (AWS). We are closely monitoring the status.
Posted Oct 20, 2025 - 16:11 UTC

Identified

These errors are due to our upstream provider (AWS) still having an ongoing outage.
Posted Oct 20, 2025 - 14:00 UTC

Investigating

We are seeing some HTTP triggers returning a 503 status and are investigating.
Posted Oct 20, 2025 - 13:10 UTC
This incident affected: Frontend (Pipedream), Backend (Event Sources - HTTP, Workflows - Timer, Workflows - HTTP, Event Sources - Timer, Pipedream destinations, Workflows - Email, GitHub Sync), Public APIs (REST API, Connect API), and Connect (Connect).