Events running against older versions of workflows

Incident Report for Pipedream

Resolved

One of the caches we use to determine the most recent version of workflow deployments appeared to be backed up, so we didn't update the most recent deployment metadata on new deploys. This led to new events triggering older workflow versions. We've addressed the underlying issue with the cache, and new deployments appear to be working as expected.
Posted May 22, 2021 - 19:30 UTC

Investigating

Users are reporting events are triggering old versions of workflows after deploying multiple, newer versions. We're investigating.
Posted May 22, 2021 - 18:21 UTC
This incident affected: Backend (Workflows - HTTP).